Conoce 10 funciones de Excel

Conoce 10 funciones de Excel

Las hojas de cálculo son una herramienta imprescindible para gestionar nuestra economía o las existencias de un negocio y ahorran tiempo y esfuerzo gracias a las funciones de Excel y otras apps.

A continuación vamos a ver las funciones de Excel más importantes:

SUMA

La función más básica de Excel es SUMA. Se aplica usando la expresión =SUMA(A1:A5). En este caso, sirve para sumar el intervalo de celdas de A1 a A5 incluyendo las que están en medio.

Entre paréntesis puedes incluir números, celdas individuales o intervalos de celdas, como en el ejemplo anterior. Otro ejemplo sería =SUMA(5;B1:B5) para sumar el intervalo B1 a B5 y a su vez sumarle 5.

 

SI

Esta función sirve para responder preguntas. Si el resultado corresponde con un valor concreto, obtendrás la respuesta que hayas configurado.

El ejemplo más sencillo es =SI(B2=1;”Sí”;”No”). Si la celda B2 tiene el valor 1, la respuesta será “Sí”. En caso contrario, en la celda de la función veremos “No”.

La función SI nos permite obtener mensajes de alerta si, por ejemplo, nuestro presupuesto excede de cierta cantidad o nuestra cuenta acaba en números negativos. Para ello, podemos usar los símbolos mayor que y menor que.

 

BUSCAR

Esta función se aplica escribiendo en una celda BUSCAR(valor_buscado; vector_de_comparación; [vector_resultado]) donde valor_buscado es lo que estamos buscando a modo de referencia (número, texto, nombre de referencia…). El vector de comparación se refiere a dónde tenemos que buscar (un intervalo de celdas, por ejemplo). En el [vector_resultado] está lo que buscamos realmente, porque lo desconocemos, a través del valor buscado.

Ejemplo: =BUSCAR(7;A2:A10;B2:B10) busca el valor 7 en las celdas comprendidas entre A2 y A10 y muestra el resultado que aparece en el intervalo B2 a B10.

 

BUSCARV

Si lo que queremos es buscar en una tabla entera, nos será más práctica la función BUSCARV.

La sintaxis es =BUSCARV(Valor que buscamos; intervalo o rango en el que buscamos ese valor; el número de columna del rango o intervalo que contiene el valor devuelto; Coincidencia exacta o Coincidencia aproximada indicado como FALSO o VERDADERO).

Por ejemplo: =BUSCARV(D13;B2:E11;3;FALSO)

 

COINCIDIR

Con COINCIDIR buscamos un elemento en un intervalo de celdas y obtendremos la posición de ese elemento en el rango que hemos indicado.

Ejemplo: =COINCIDIR(5;A1:A10;0)

5 es el valor que buscamos dentro de una celda situada entre A1 y A10. Por último 0 se refiere a qué tipo de coincidencia buscamos.

Hay tres tipos de coincidencia: 1 muestra el valor mayor que es menor o igual que el valor buscado. 0 muestra el primer valor exactamente igual que el valor buscado. -1 muestra el valor menor que es mayor o igual que el valor buscado.

 

ELEGIR

Con la función ELEGIR obtendremos un valor de una lista de hasta 254 posibles.

En el ejemplo =ELEGIR(2;A2;A3;A4;A5) se mostrará el segundo valor del rango A2 a A5. Lamentablemente, tenemos que incluir cada celda en vez de indicar un intervalo.

 

FECHA

Con esta función obtendremos una fecha a partir de tres valores diferentes. En concreto, año, mes y día, por ese orden.

Por ejemplo, =FECHA(C2,A2,B2) muestra el año de la celda C2, el mes de la celda A2 y el día de la celda B2. Para evitar problemas, es recomendable mostrar los años con cuatro cifras.

El resultado se mostrará con un formato u otro según lo tengamos configurado. Podemos cambiarlo desde Formato > Formato de celdas > Número > Fecha.

 

DIAS

La función DIAS sirve para mostrar el número de días transcurridos entre dos fechas distintas.

Con la expresión =DIAS(fecha final; fecha inicial) obtendremos el resultado en forma de valor numérico.

Ejemplo: =DIAS(A5;A1) o =DIAS(03/08/2003;05/03/1997). Las dos maneras son posibles. En este caso, el resultado será 2342 días.

 

ENCONTRAR Y ENCONTRARB

Con estas dos funciones encontraremos una cadena de texto dentro de una segunda cadena. El resultado obtenido será la posición inicial de la primera cadena de texto.

Ambas funciones se utilizan con la estructura =ENCONTRAR(texto_buscado; dentro_del_texto; [núm_inicial]).

En texto buscado indicamos la expresión escrita que buscamos entrecomillada. En dentro del texto indicamos la celda donde se encuentra, por ejemplo A1. Opcionalmente, podemos indicar un número inicial para que la búsqueda empiece a partir de un carácter concreto.

Estas funciones te serán útiles si en una columna incluyes conceptos complejos combinados y necesitas extraer una parte.

 

INDICE

Por último, INDICE nos da un valor o referencia de una celda o matriz de celdas desde una tabla o rango.

Con =INDICE(matriz; núm_fila; [núm_columna]) indicamos la matriz donde buscar (un rango entre dos celdas de una o más columnas), el número de la fila donde buscar y, si hay varias columnas en la matriz, el número de la columna donde devolver un valor. El resultado será este último valor.

Ejemplo: =INDICE(A1:B5;2;2 donde A1:B5 es la matriz que integra las columnas A y B desde las filas 1 a 5. El primer 2 se refiere a que queremos el valor de la segunda fila, y como en la matriz hay dos columnas, incluimos otro 2 para indicar que queremos el valor de la segunda columna.

Share on facebook
Facebook
Share on twitter
Twitter
Share on linkedin
LinkedIn

Deja una respuesta

Tu dirección de correo electrónico no será publicada.Los campos obligatorios están marcados *

FacebookLinkedInInstagram
Abrir chat